[CentOS] rpm dependencies

Joe Keller joseph.w.keller at gmail.com
Mon Nov 29 11:50:14 EST 2010


When you built openssh, didn't it also build the openssh-clients and
openssh-server RPMs?  You should install them at the same in the same
transaction with your version of openssh:

rpm -Uvh openssh*-5.6p1-1.i386.rpm

On Mon, Nov 29, 2010 at 11:23 AM, bluethundr <bluethundr at gmail.com> wrote:

>  I have successfully created a packaged version of openssh that has
> the LPK patch.  LPK allows you to store your public keys in LDAP.
> However when I go to install the package I created it complains about
> dependencies:
>
> [root at VIRTCENT13:/home/bluethundr/rpm]#rpm -Uvh openssh-5.6p1-1.i386.rpm
> error: Failed dependencies:
>        openssh = 5.5p1-1.el5 is needed by (installed)
> openssh-clients-5.5p1-1.el5.i386
>        openssh = 5.5p1-1.el5 is needed by (installed)
> openssh-server-5.5p1-1.el5.i386
>
>  how can I get past this?
>
> thanks!!
>
>
> --
> Here's my RSA Public key:
> gpg --keyserver pgp.mit.edu --recv-keys B6D6EAC3
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20101129/6086447c/attachment.html 


More information about the CentOS mailing list