[CentOS] yum is dumb in update of gmime & gmime-sharp

William Hooper whooperhsd at gmail.com
Mon Nov 29 14:16:04 EST 2010


On Mon, Nov 29, 2010 at 11:33 AM, ken <gebser at mousecar.com> wrote:
> Where was a message telling me that?  (In my original post I included
> the relevant output.)  There wasn't anything there which said the
> install of gmime20 necessitated removing another, different package.

I'll try to explain, but part of it just comes from experience.

    ---> Package gmime20.i386 0:2.2.26-1.el5.rf set to be updated

This is the package being installed.

     --> Finished Dependency Resolution
     gmime-sharp-2.2.10-5.el5.centos.i386 from installed has depsolving problems
     --> Missing Dependency: gmime = 2.2.10-5.el5.centos is needed by
    package gmime-sharp-2.2.10-5.el5.centos.i386 (installed)

The "from installed" means the that package in question (gmime-sharp)
is already installed.  The assumption I made, since you provided the
output saying that gmime of an appropriate version was installed, is
that yum is saying the gmime version needed would be removed.
Checking the spec file and finding the obsoletes confirms that.

Yum used to give similar messages when you tried to "yum erase" a
package that would break dependencies.  Newer versions of yum just
walk down the tree and offer to remove half the system, instead.

-- 
William Hooper


More information about the CentOS mailing list