[CentOS] yum update error

John Doe jdmls at yahoo.com
Mon Oct 11 09:13:53 EDT 2010


From: Timothy Murphy <gayleard at eircom.net>

> For some reason all the perl man pages cause yum errors  like
> -------------------------------------
> Transaction Check  Error:
>   file /usr/share/man/man1/c2ph.1.gz from install of
>    perl-5.8.8-32.el5_5.2.x86_64 conflicts with file from package
>    perl-5.8.8-32.el5_5.1.i386
> -------------------------------------
> 1. I  don't really see how the man pages can cause conflicts;
> 2. More importantly,  how should I deal with this?

Simply because both packages contain several identical (as in filepath) files...
You try to install two versions of the perl package at the same time.
You have an old i386 version and try to install a newer x86_64.
I think I would remove the old i386 version and install the newer x86_64.

JD


      


More information about the CentOS mailing list