[CentOS] Openwebmail emergency (Perl)

Jussi Hirvi listmember at greenspot.fi
Tue Oct 12 02:51:40 EDT 2010


It seems Openwebmail is using Perl-Compress-Zlib from rpmforce, but in 
Centos this is obsoleted by Perl-IO-Compress, and there is a conflict.

This I got when I tried to install the rpmforce package:

[root at mail log]# yum install perl-Compress-Zlib
Loaded plugins: fastestmirror, installonlyn
Loading mirror speeds from cached hostfile
  * addons: ftp.funet.fi
  * base: ftp.funet.fi
  * extras: ftp.funet.fi
  * rpmforge: wftp.tu-chemnitz.de
  * updates: ftp.funet.fi
Setting up Install Process
Package perl-Compress-Zlib is obsoleted by perl-IO-Compress, trying to 
install perl-IO-Compress-2.030-2.el5.rf.noarch instead
Package perl-IO-Compress-2.030-2.el5.rf.noarch already installed and 
latest version
Nothing to do

- Jussi

On 12.10.2010 9.38, Jussi Hirvi wrote:
> Ok, more information. I have Openwebmail 2.52. I tried to install 2.53
> with yum, and get the following. This points to what the conflict is
> about. But I still don't know how to fix this.
> - Jussi
>
> Installing:
>    openwebmail                  i386             2.53-3
>           openwebmail           2.4 M
> Installing for dependencies:
>    openwebmail-data             i386             2.53-3
>           openwebmail           7.3 M
>    perl-Compress-Zlib           noarch           2.015-1.el5.rf
>           rpmforge               34 k
>    perl-suidperl                i386             4:5.8.8-32.el5_5.2
>           updates                62 k
>
> Transaction Summary
> ===========================================================================================================
> Install       4 Package(s)
> Upgrade       0 Package(s)
>
> Total size: 9.9 M
> Total download size: 62 k
> Is this ok [y/N]: y
> Downloading Packages:
> perl-suidperl-5.8.8-32.el5_5.2.i386.rpm
>               |  62 kB     00:00
> Running rpm_check_debug
> Running Transaction Test
> Finished Transaction Test
>
>
> Transaction Check Error:
>     file /usr/lib/perl5/vendor_perl/5.8.8/Compress/Zlib.pm from install
> of perl-Compress-Zlib-2.015-1.el5.rf.noarch conflicts with file from
> package perl-IO-Compress-2.030-2.el5.rf.noarch
>     file /usr/share/man/man3/Compress::Zlib.3pm.gz from install of
> perl-Compress-Zlib-2.015-1.el5.rf.noarch conflicts with file from
> package perl-IO-Compress-2.030-2.el5.rf.noarch
>
>
>
>


-- 
Jussi Hirvi * Green Spot
Topeliuksenkatu 15 C * 00250 Helsinki * Finland
Tel. +358 9 493 981 * Mobile +358 40 771 2098 (only sms)
jussi.hirvi at greenspot.fi * http://www.greenspot.fi


More information about the CentOS mailing list