[CentOS] Who maintains php-pgsql package? I want to ask about using PostgreSQL 8.4 library instead of PostgreSQL 8.1.

Aleksey Tsalolikhin atsaloli.tech at gmail.com
Mon Oct 18 16:08:13 EDT 2010


How do I find out who is the maintainer of the php-pgsql package, please?
I want to request upgrade from underlying postgresql-libs-8.1.21
(/usr/lib64/libpq.so.4) to postgresql84-libs-8.4.4 (/usr/lib64/libpq.so.5.2).

Background on this request:  Apache httpd's php's php-pgsql uses
PostgreSQL 8.1 library (/usr/lib64/libpq.so.4), which leaks memory.
PostgreSQL 8.4 library does not leak.

    Apache HTTP Server: httpd-2.2.3-43.el5.centos.3

    mod_php: php-5.1.6-27.el5

    PHP PostgreSQL interface is provided by: php-pgsql-5.1.6-27.el5,
which uses postgresql-libs-8.1.21-1.el5_5.1 which provides
/usr/lib64/libpq.so.4 which we've observed has a memory leak
(and this memory leak is NOT present in libpq.so.5.2)

  I am trying to figure out how to get our httpd/mod_php/php-pgsql
to use libpq.so.5.2 instead of libpq.so.4, and I thought I'd start by
asking the php-pgsql maintainer, so this problem is fixed for everybody,
not just for me.

  Please let me know if I can help in any way.

Kind regards,
Aleksey


More information about the CentOS mailing list