[CentOS] missing dependency for package

Ski Dawg centos at skidawg.org
Thu Oct 21 13:21:02 EDT 2010


Hello everyone,

I know this isn't strictly CentOS query, but I am hoping that someone
here with more experience than myself might have some thoughts.

I am trying to get a plugin working for Ganglia on a CentOS 5.5 box,
in a testing environment. The plugin is for apache monitoring, called
Ganglia-Logtailer. This plugin requires the executable
/usr/bin/logtail in order to work. The only packages that have this
executable, that I have been able to find, is part of the epel-testing
repository in the logcheck package. When I try to install the package
from that repository, it is missing the dependency,
perl-mime-construct, which I am not able to find packaged anywhere.

It appears that the logcheck package includes several other
executables that I do not need, and those other executables are what
requires the perl-mime-construct package.

My question is, does anyone know of a source to get this package that
would also include the necessary requirements? If not, any way that I
can rebuild the source package, and remove the things that I do not
need, and thus removing their dependencies? If I have to maintain my
own package for this, I can, but I would prefer another option, if
available. Any other way of getting this single executable that anyone
can think of?

-- 
Doug

Registered Linux User #285548 (http://counter.li.org)
----------------------------------------
Never trust a computer you can't throw out a window.
   -- Steve Wozniak


More information about the CentOS mailing list