[CentOS] can't install mono-devel because mono-basic requires mono-core. But I have mono-core! What to do? I need gmcs.

Aleksey Tsalolikhin atsaloli.tech at gmail.com
Mon Oct 25 20:39:25 EDT 2010


Turned out I had multiple repo's in play.  mono-basic from one repo,
and mono-core from another.
I removed both and ran "yum install mono-devel" and it installed fine
from "epel" with all dependecies.

Cheers,
-at

On Mon, Oct 25, 2010 at 4:52 PM, Aleksey Tsalolikhin
<atsaloli.tech at gmail.com> wrote:
> Hi.  I'm trying to install gmcs so that I can build gbrainy, a mental exerciser.
>
> I am not sure what package provides, maybe mono-devel?  however mono-devel
> fails to install because, it says, mono-basic requires mono-core.  I
> have mono-core
> installed.  Why is this failing?
>
>
> $ sudo yum install mono-devel.i386
> ...-> Finished Dependency Resolution
> mono-basic-1.0.6-1.el5.rf.i386 from installed has depsolving problems
>  --> Missing Dependency: mono-core = 1.0.6-1.el5.rf is needed by
> package mono-basic-1.0.6-1.el5.rf.i386 (installed)
> Error: Missing Dependency: mono-core = 1.0.6-1.el5.rf is needed by
> package mono-basic-1.0.6-1.el5.rf.i386 (installed)
>  You could try using --skip-broken to work around the problem
>  You could try running: package-cleanup --problems
>                        package-cleanup --dupes
>                        rpm -Va --nofiles --nodigest
> $ rpm -q mono-core
> mono-core-1.0.6-1.el5.rf
> $
>
> Any suggestions?
>
> Thanks,
> -at
>


More information about the CentOS mailing list