[CentOS] Issue with Perl and rpmforge - advice?

Mark mhullrich at gmail.com
Wed Sep 1 21:51:55 EDT 2010


I have an old version of rkhunter installed on my CentOS 5 machine,
one I got from rpmforge.

In my most recent attempts to update this, I get the following errors in yum:

Resolving Dependencies
--> Running transaction check
---> Package perl-AnyEvent.noarch 0:5.240-1.el5.rf set to be updated
--> Processing Dependency: perl(JSON::XS) >= 2.2 for package: perl-AnyEvent
--> Processing Dependency: perl(JSON) >= 2.09 for package: perl-AnyEvent
--> Processing Dependency: perl(EV) >= 3.05 for package: perl-AnyEvent
--> Processing Dependency: perl(Guard) >= 1.02 for package: perl-AnyEvent
--> Processing Dependency: perl(Net::SSLeay) >= 1.33 for package: perl-AnyEvent
---> Package perl-Compress-Raw-Bzip2.x86_64 0:2.024-1.el5.rf set to be updated
---> Package perl-Compress-Raw-Zlib.x86_64 0:2.024-1.el5.rf set to be updated
---> Package perl-Error.noarch 0:0.17016-1.el5.rf set to be updated
---> Package perl-Event.x86_64 0:1.13-1.el5.rf set to be updated
---> Package perl-Event-ExecFlow.x86_64 0:0.64-1.el5.rf set to be updated
---> Package perl-IO-AIO.x86_64 0:3.310-1.el5.rf set to be updated
---> Package perl-IO-Compress.noarch 0:2.024-1.el5.rf set to be updated
---> Package perl-common-sense.x86_64 0:3.0-1.el5.rf set to be updated
---> Package rkhunter.noarch 0:1.3.6-1.el5.rf set to be updated
--> Processing Dependency: perl(Digest::SHA256) for package: rkhunter
--> Processing Dependency: perl(Digest::SHA::PurePerl) for package: rkhunter
--> Running transaction check
---> Package perl-AnyEvent.noarch 0:5.240-1.el5.rf set to be updated
--> Processing Dependency: perl(Net::SSLeay) >= 1.33 for package: perl-AnyEvent
---> Package perl-Digest-SHA-PurePerl.noarch 0:5.48-1.el5.rf set to be updated
---> Package perl-EV.x86_64 0:3.9-1.el5.rf set to be updated
---> Package perl-Guard.x86_64 0:1.021-1.el5.rf set to be updated
---> Package perl-JSON.noarch 0:2.17-1.el5.rf set to be updated
---> Package perl-JSON-XS.x86_64 0:2.27-1.el5.rf set to be updated
---> Package perl-SHA256.x86_64 0:0.01b-1.2.el5.rf set to be updated
--> Finished Dependency Resolution
perl-AnyEvent-5.240-1.el5.rf.noarch from rpmforge has depsolving problems
  --> Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by
package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

This seems to be because my current perl installation has the following:

perl-Net-SSLeay.x86_64                     1.30-4.fc6                  installed

IIRC, this is part of the base perl package, which repo has higher
priority than the rpmforge repo (of course), which in turn makes the
rpmforge perl packages invisible.

Questions:

1) Are the newer perl packages from rpmforge compatible with the
installed base perl packages?

2) What other implications should I be looking for if I try this
(other than the obvious caveat about other rpmforge rpms breaking
other base rpms)?

There's a fair amount of perl support in the installed base, I just
want to be sure I'm not likely to break it.

Thanks.

Mark


More information about the CentOS mailing list