[CentOS] Wrapper package / yum repository

Gabriel Tabares gabriel.tabares at roboreus.com
Wed Sep 8 04:24:10 EDT 2010


  On 07/09/2010 17:47, Steve Huff wrote:
> On Sep 7, 2010, at 11:28 AM, Gabriel Tabares wrote:
>
>> tomcat-6.0.26-1.13
>> adm-app-conf-18-2010.09.01
>> jdk-1.6.0_20-2.0
>> ant-1.8.1-1
>
> there's your problem.  in the specfile, these dependencies should be specified as:
>
> Requires: tomcat>= 6.0.26
> Requires: adm-app-conf>= 18
> ...
>
> relevant API documentation is here:
>
> http://rpm5.org/docs/api/dependencies.html
>
Thanks, that fixed it.

I never read the documentation and was fooled by the fact that it listed 
the rpms with the right version number.





More information about the CentOS mailing list