[CentOS] logwatch question

lostson lostson at lostsonsvault.org
Wed Sep 29 17:43:22 EDT 2010


Quoting Mário Barbosa <mplbarbosa at clix.pt>:

> LostSon wrote:
>> Yes I did run newaliases and still no joy
>>
>> Mark Van Bogart <mark.vanbogart at gmail.com> wrote:
>>
>>> Did you run 'newaliases' after editing /etc/aliases?
>>>
>>> Sent from my iPhone
>>>
>>> On Sep 28, 2010, at 6:27 AM, lostson <lostson at lostsonsvault.org> wrote:
>>>
>>>> Hello
>>>> A few weeks ago I started having problems with my system email or
>>>> specifically my logwatch reports showing up in my inbox. I got most of
>>>> those issues figued out except one now when i get an email from my
>>>> system it has a title of this
>>>>
>>>> Cron <root at localhost> run-parts /etc/cron.daily
>>>>
>>>>
>>>> with this message
>>>>
>>>> /etc/cron.daily/0logwatch:
>>>>
>>>> Recipient names must be specified
>
>
> http://linuxhelp.blogspot.com/2005/06/sendmail-versatile-mail-server.html
>
> Look for "Check if sendmail is identifying your station's hostname
> correctly:"
>

  Well a few weeks ago after updating, my logwatch reports just  
stopped, i had some
permission problems and other such things. So last night what i did was

  yum remove sendmail logwatch

  then i reinstalled them and was gettting the error
  logwatch cannot execute sendmail -t

  turns out that in the  /usr/share/---  logwatch.conf its says mailer  
= " sendmail -t"

  but that kicks in the error so in etc/logwatch/logwatch.conf if you add
  mailer = "/usr/sbin/sendmail -t"
  then the error goes away and logwatch reports start flowing back to  
my inbox like normal
so that fixed my error and all is well now. Talking with people last  
night they said it
was weird probably that a symlink was pointing to where it should be.  
Weird thing was i
did a fresh install on my laptop while working on my main machine last  
night and was
getting the exact same issue on a fresh install. but again applying  
this fix made it work
fine. So the question is now is, is it a logwatch issue or a sendmail  
issue and if so
where and how to fix
it. I'm gonna write up a full bug report hopefully tonight and look  
upstream as well to
see if there are any bugs filed with RH about this as well.

  LostSon

  http://lostsonsvault.org






More information about the CentOS mailing list