[CentOS] Some relevant information

Nico Kadel-Garcia nkadel at gmail.com
Wed Mar 23 08:53:46 EDT 2011


On Wed, Mar 23, 2011 at 5:42 AM, Johnny Hughes <johnny at centos.org> wrote:

>
> And then looking at the reason for the fails:
>
> Differing package requirements certmonger-0.30-4.el5.x86_64.rpm.out:
> --- work/SL-req         2011-03-23 02:53:25.000000000 -0500
> +++ work/RHEL-req       2011-03-23 02:53:25.000000000 -0500
> @@ -38,7 +38,7 @@
>  libpthread.so.0(GLIBC_2.2.5)(64bit)
>  libsmime3.so()(64bit)
>  libssl3.so()(64bit)
> -libtalloc.so.1()(64bit)
> +libtalloc.so.2()(64bit)
>  libtevent.so.0()(64bit)
>  libxmlrpc.so.3()(64bit)
>  libxmlrpc_client.so.3()(64bit)
>
>
> Differing package requirements libtevent-0.9.8-10.el5.x86_64.rpm.out:
> --- work/SL-req     2011-03-23 02:53:26.000000000 -0500
> +++ work/RHEL-req       2011-03-23 02:53:26.000000000 -0500
> @@ -5,7 +5,7 @@
>  libc.so.6(GLIBC_2.3.2)(64bit)
>  libc.so.6(GLIBC_2.3.4)(64bit)
>  libc.so.6(GLIBC_2.4)(64bit)
> -libtalloc.so.1()(64bit)
> +libtalloc.so.2()(64bit)
>  libtevent.so.0()(64bit)
>  rpmlib(CompressedFileNames) <= 3.0.4-1
>  rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> =========================================================================================
>
> What does that mean ... it means that those 2 packages were built
> against the wrong version of libtalloc.  Those packages use the older

Ouch. Johnny, I'd really like to replicate this error, but I just
don't have the visibility into your build configurations. Saying "it's
easy to do yourself" doesn't work, because there are subtleties in the
configurations, such as whether "mock" configurations use the older,
CentOS 5.5 release or the existing set up updated CentOS pre-release
5.6 components, that can generate precisely this sort of issue.


More information about the CentOS mailing list