[CentOS] CentOS 6.2 software raid 10 with LVM - Need help with degraded drive and only one MBR

Jonathan Vomacka juvix88 at gmail.com
Fri Mar 2 15:14:16 EST 2012


Digimer! Thanks for the info. Since the HDD0 drive is completely failed, 
I would need to replace it.. it doesn't have any data on it. The other 
three HDD's would need the MBR. I am assuming... that because RAID 10 
means Striped+Mirroring that HDD 3+4 would be mirrored and 1+2 would be 
mirrored... is this an accurate statement?

On 3/2/2012 12:07 PM, Digimer wrote:
> On 03/02/2012 09:03 AM, Jonathan Vomacka wrote:
>> CentOS Community,
>>
>> I have a dedicated server with 4 hard drives in a RAID 10 software
>> configuration running LVM. My OS is CentOS 6.2. Earlier today, I
>> rebooted my system and my system did not come back online. I opened a
>> ticket with my datacenter who informed me that one of my hard drives is
>> no longer recognized by the bios and has failed. I was told that an OS
>> reinstall was needed.
>>
>> I don't understand why a reinstall would be necessary when the drives
>> are in RAID 10. Apparently when the datacenter did the initial OS
>> install, they ONLY installed the MBR on one drive instead of all 4
>> leaving the other 3 drives unbootable.
>>
>> Is this a way to salvage this with a liveCD without having to reload the
>> OS? This server is a very important mail server running OpenLDAP and
>> MySQL. I figured maybe I could install the MBR using a liveCD which may
>> fix the system.
>>
>> If an OS reload is the ONLY option, is there a way to reload it without
>> touching the /var or /opt filesystems? (yes they were created as a
>> seperate partition) however I am not sure if OpenLDAP or MySQL installs
>> anything to /usr which I would be completely screwed...
>>
>> Please help
>
> Advice provided as-is.
>
> Boot from a live CD using the CentOS 6.2 install media. Once booted:
>
> <bash># grub
> <grub>  root (hd0,0)
> <grub>  setup (hd0)
> <grub>  root (hd1,0)
> <grub>  setup (hd1)
> <grub>  root (hd2,0)
> <grub>  setup (hd2)
> <grub>  quit
> <bash># reboot
>
> This assumes that grub sees the drives at '0, 1 and 2' and the boot
> partition is the first on each drive. If it is, when you type 'root
> (hdX,0)' it should report that a file system was found. The 'setup
> (hdX)' will tell grub to write the MBR to the specified disk.
>


More information about the CentOS mailing list