[CentOS] Dependency issues when running yum update

Lamar Owen lowen at pari.edu
Sat Mar 10 11:49:02 EST 2012


On Saturday, March 10, 2012 10:49:46 AM Phil Savoie wrote:
> ---> Package xulrunner.i686 0:1.9.2.26-2.el6.centos will be updated
> --> Processing Dependency: libmozjs.so for package:
> gxine-0.5.905-1.el6.rf.i686
> --> Finished Dependency Resolution
> Error: Package: gxine-0.5.905-1.el6.rf.i686 (@rpmforge)
>            Requires: libmozjs.so

> Running the --skip-broken gets me updated but the problem is still
> there.  Would anyone have an idea as to how to fix this, please?

Not trying to be a smart aleck here, but the problem isn't with CentOS, but with a third-party package; you may want to ask on an RPMforge list about an update to gxine, which is not a CentOS package, but an RPMforge package.  More than likely, with the historically great responsiveness of the RPMforge maintainers (especially Dag) this will be fixed shortly, since the same thing will impact any EL6 rebuild and upstream EL6 itself.  So try again later, or run the update with --disablerepo=rpmforge


More information about the CentOS mailing list