[CentOS] Dependency issues when running yum update

Lamar Owen lowen at pari.edu
Sat Mar 10 19:48:22 EST 2012


On Mar 10, 2012, at 7:14 PM, Keith wrote:

> On 11/03/12 02:49, Phil Savoie wrote:
>> --->  Package xulrunner.i686 0:1.9.2.26-2.el6.centos will be updated
>> -->  Processing Dependency: libmozjs.so for package:
>> gxine-0.5.905-1.el6.rf.i686
>> -->  Finished Dependency Resolution
>> Error: Package: gxine-0.5.905-1.el6.rf.i686 (@rpmforge)
>>            Requires: libmozjs.so
>>            Removing: xulrunner-1.9.2.26-2.el6.centos.i686 (@updates)
>>                libmozjs.so
>>            Updated By: xulrunner-10.0.1-2.el6.centos.i686 (updates)
>>                Not found
>>            Available: xulrunner-1.9.2.24-2.el6.centos.1.i686 (base)
>>                libmozjs.so
>>            Available: xulrunner-1.9.2.26-1.el6.centos.i686 (updates)
>>                libmozjs.so
>>   
> Have you configured Priorities?
> I've mainly found these sorts of issues to be related with priorities 
> not configured - may not be your case, but I would double check anyway.

In this specific case, and while this isn't the RPMforge list, but, anyway, it appears that the update of xulrunner (associated with the new Firefox, I believe) no longer provides some specific library that the rpmforge gxine package depends upon, and thus yum couldn't do the upgrade of xulrunner because the new package doesn't seem to provide that dependency any more. I of course reserve the right to be wrong. 

It's not something that can be fixed by CentOS, it will have to be fixed by rpmforge, as that gxine package will have to be upgraded to use something else that provides libmozjs.so.  (that's where the 'Not found' under the xulrunner 10.0.1 package comes from).



More information about the CentOS mailing list