[CentOS] [SOLVED] perl-DBD-MySQL, libmysqlclient.16 and 5.7 (FInal)

Ilya Kazakevich kazakevichilya at gmail.com
Tue Mar 13 18:18:10 EDT 2012


On Wed, Mar 14, 2012 at 1:45 AM, Les Mikesell <lesmikesell at gmail.com> wrote:

> On Tue, Mar 13, 2012 at 4:41 PM, Ilya Kazakevich
> <kazakevichilya at gmail.com> wrote:
> > Thanks.
> > My problem is stupid: person who installed MySQL on this server did not
> use
> > yum repositories at all!
> > I have "MySQL-shared-community-5.*1*.57-1.rhel5" installed (according to
> > rpm -qa) while yum repositories have 5.*0*.95 (according to repoquery -i
> > mysql) and it leads to inconsistency. I think 15 version of
> libmysqlclient
> > is for 5.0 while 16 is for 5.1.
> >
> > I believe someone have asked IT person to install mysql 5.1. Person found
> > that CentOS 5.7 repositories have no 5.1, so he installed it from
> external
> > .rpm file (because he did not want to upgrade the whole system).
> >
>
> There have been a lot of security-related fixes since 5..1.
>
>
I know but I do not want to update it now.
I tried to use cpan, but it needs mysql_config (tool that tells it which
options should be used for mysql) and my MySQL package has no such tool.

At least I installed libmysqlclient15 using yum from webtatic repo and now
I have 2 of them, so my "mysql" app would use 16 while perl-DBD-mysql
(which installed successfully now) should use 15.

Hope 15 is ok for my perl app.

Thanks.


More information about the CentOS mailing list