[CentOS] qemu-kvm for Centos 5 x86

Anton Zaytsev anton.zajtsev at gmail.com
Fri Mar 16 11:40:13 EDT 2012


On Fri, Mar 16, 2012 at 4:42 PM, Johnny Hughes <johnny at centos.org> wrote:
> On 03/16/2012 12:58 AM, Bob Puff wrote:
>> Hey gang,
>>
>> I have been trying my hardest to get KVM running on a 32-bit CentOS 5.  I know
>> "upstream doesn't support it", but from what I gather, it *is* possible.
>>
>> I've tried downloading the KVM source, but get nailed on compile with:
>>
>>   LINK  i386-softmmu/qemu
>> make -C /lib/modules/2.6.18-308.1.1.el5PAE/build M=`pwd` \
>>                 LINUXINCLUDE="-I`pwd`/include -Iinclude \
>>                  -Iarch/x86/include -I`pwd`/include-compat \
>>                 -include include/linux/autoconf.h \
>>                 -include `pwd`/x86/external-module-compat.h " \
>>                 "$@"
>>   LD      /usr/local/kvm-88/kvm/kernel/x86/built-in.o
>>   CC [M]  /usr/local/kvm-88/kvm/kernel/x86/svm.o
>> In file included from
>> /usr/local/kvm-88/kvm/kernel/x86/external-module-compat.h:16,
>>                  from <command line>:1:
>> /usr/local/kvm-88/kvm/kernel/x86/../external-module-compat-comm.h:551: error:
>> static declaration of âcancel_work_syncâ follows non-static declaration
>> include/linux/workqueue.h:117: error: previous declaration of cancel_work_sync
>> was here
>> In file included from
>> /usr/local/kvm-88/kvm/kernel/x86/external-module-compat.h:16,
>>                  from <command line>:1:
>> /usr/local/kvm-88/kvm/kernel/x86/../external-module-compat-comm.h:607: error:
>> expected identifier or ( before { token
>> In file included from
>> /usr/local/kvm-88/kvm/kernel/x86/external-module-compat.h:16,
>>                  from <command line>:1:
>> /usr/local/kvm-88/kvm/kernel/x86/../external-module-compat-comm.h:717: error:
>> conflicting types for smp_call_function_many
>> include/asm/smp.h:46: error: previous declaration of smp_call_function_many
>> was here
>> make[4]: *** [/usr/local/kvm-88/kvm/kernel/x86/svm.o] Error 1
>> make[3]: *** [/usr/local/kvm-88/kvm/kernel/x86] Error 2
>> make[2]: *** [_module_/usr/local/kvm-88/kvm/kernel] Error 2
>> make[1]: *** [all] Error 2
>> make: *** [kvm-kmod] Error 2
>>
>>
>> Has anyone built RPM packages for this?  Ideas on how to compile?  I'm running
>> the kernel: 2.6.18-308.1.1.el5PAE
>
> There is no way you are going to build anything that new (kvm-88) for
> the 2.6.18 kernel
>
> The real problem is that RH has backported a bunch of items into the
> 2.6.18 kernel, otherwise you would not be able to attempt this at all.
>
> KVM recommends at least a 2.6.20 kernel to use a very old version of KVM
> (kvm-17):
> http://www.linux-kvm.org/page/Choose_the_right_kvm_%26_kernel_version
>
> I would look at this version:
> http://vault.centos.org/5.6/centosplus/SRPMS/kvm-kmod-36-3.src.rpm
>
> (which did work on i686)
>
> I would see if I could look at what patches, etc, are in that SRPM and I
> would see if I could do anything similar with newer versions of KVM.
>
> BUT ... the bottom line is that if it was stable, Red Hat would release
> it for RHEL.  Since they do not do so, it is likely not stable and
> making it stable will likely be very difficult.  If if was not
> difficult, then Red Hat would do  it for RHEL :D
>
>
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>

Hi, Ljubomir Ljubojevic has shared his repo, which has kvm-84 and
kmod-kvm-84 packages. They are perfectly fit latest kernel
2.6.18-308.1.1.el5 (not PAE).
I've installed them without issues. KVM module loads in the kernel. I
have not tried anything yet. But suppose it'll work.

http://rpms.plnet.rs/plnet-centos5-i386/RPMS.plnet/
http://rpms.plnet.rs/plnet-centos5-i386/RPMS.plnet-releases/plnet-ser-release-1.0-0.el5.noarch.rpm


More information about the CentOS mailing list