[CentOS] Ndiswrapper refuses to install?

Akemi Yagi amyagi at gmail.com
Fri Mar 23 19:48:37 EDT 2012


On Fri, Mar 23, 2012 at 3:28 PM, Marko Vojinovic <vvmarko at gmail.com> wrote:
> On Friday, 23. March 2012. 21.36.54 Ned Slider wrote:

> I see. Well, I just tried to install it, and it fails again, this time with a
> similar but different error:
>
> # yum --enablerepo=elrepo-testing install kmod-ndiswrapper
> [snip regular stuff]
> Error: Package: kmod-ndiswrapper-1.57-0.1.rc1.el6.elrepo.i686 (elrepo-testing)
>           Requires: ksym(__vmalloc) = 0x5705088a

This is a known issue. NedSlider should have mentioned the upstream
bug he himself reported. :-P

https://bugzilla.redhat.com/show_bug.cgi?id=767738

Now the bug has been fixed upstream and so the kmod-ndiswrapper needs
to be rebuilt. But this is a moot point here because
kmod-compat-wireless seems to be working for you.

>> http://elrepo.org/tiki/kmod-compat-wireless
>
> This looks interesting. I just installed it, and it seems to be working! After
> plugging in the USB dongle, /var/log/messages correctly recognizes the device:

> And lsusb now reports:
>
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 002: ID 1286:1fab Marvell Semiconductor, Inc. 88W8338
> [Libertas] 802.11g
>
> Both "Tenda" and "Marvell" are correct. Now I'll try to start NetworkManager
> and see if I can get it to connect... :-)

Your vendor:device ID pair (1286:1fab) is indeed listed on the web
page above and the blog [1]. The whole conversation should have taken
place in the ELRepo mailing list as pointed out earlier, but other
CentOS users might benefit from the info, this thread should be useful
in this mailing list. :-)

Akemi

[1] http://elrepoproject.blogspot.com/2012/03/one-size-fits-all-compat-wireless-fits.html


More information about the CentOS mailing list