[CentOS] build postfix rpm with mysql

Johnny Hughes johnny at centos.org
Sun Mar 25 07:23:14 EDT 2012


On 03/25/2012 12:06 AM, Cliff Pratt wrote:
> On Sun, Mar 25, 2012 at 3:32 PM, Tim Dunphy <bluethundr at gmail.com> wrote:
>> hello list,
>>
>>  I'm trying to build a postfix rpm that has mysql support included.
>> I've found the line where I need to define mysql support but it seems
>> that I am being tripped up by some build dependencies:
>>
>>  [root at beta SPECS]# rpmbuild -ba postfix.spec
>> error: Failed build dependencies:
>>        MySQL-shared is needed by postfix-2.9.1-1.rhel5.x86_64
>>        MySQL-devel is needed by postfix-2.9.1-1.rhel5.x86_64
>>
> Why don't you just install the packages?
>

Those package names do not match up with the names in Fedora / Red Hat /
CentOS land ... they are the names of the RPMs from mysql.

Change the build requirement to:

BuildRequires:  mysql-devel

I assume that you want to run a postfix that is newer than the one in
CentOS (the one from upstream) or that you would not be doing this ...
BUT ... if you are only looking for mysql support, then you can just
grab the latest CentOS SRPM and change the configure section of the SRPM
to add mysql support.

You will be on your own to figure out any other dependencies though,
like sasl, etc. if you get the packages from upstream.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
Url : http://lists.centos.org/pipermail/centos/attachments/20120325/55a750e0/attachment.bin 


More information about the CentOS mailing list