[CentOS] Problem with PHP / Postgresql on CentOS6.2

Rudinei Dias rudinei.dias at gmail.com
Tue Mar 27 08:49:17 EDT 2012


HI.

I have instaled a WEB server with Postgresql on CentOS 6.2.
PostgreSQL, versin 9.1.3 x64 from EntrrpriseDB base *.run*.
PHP with PDO from YUM using reposity versions.

On start apache does not get error. PHP LOG under, with PDO error.

*PHP Warning:  PHP Startup: Unable to load dynamic library
'/usr/lib64/php/modules/pdo_pgsql.so' - libpq.so.5: failed to map segment
from shared object: Permission denied in Unknown on line 0
*PHP Warning:  PHP Startup: Unable to load dynamic library
'/usr/lib64/php/modules/pdo_pgsql.so' - libpq.so.5: failed to map segment
from shared object: Permission denied in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library
'/usr/lib64/php/modules/xsl.so' - libxslt.so.1: failed to map segment from
shared object: Permission denied in Unknown on line 0
[Tue Mar 27 09:35:17 2012] [notice] Apache/2.2.15 (Unix) DAV/2 PHP/5.3.3
mod_ssl/2.2.15 OpenSSL/1.0.0-fips configured -- resuming normal operations

I try to reinstall all PHP modules and get this messages

  Installing :
php-xml-5.3.3-3.el6_2.6.x86_64
14/24
  Installing :
php-intl-5.3.3-3.el6_2.6.x86_64
15/24
  Installing :
php-embedded-5.3.3-3.el6_2.6.x86_64
16/24
*/sbin/ldconfig: /opt/PostgreSQL/psqlODBC/lib/libpq.so.5 is not a symbolic
link*
  Installing :
php-soap-5.3.3-3.el6_2.6.x86_64
17/24
  Installing :
php-mbstring-5.3.3-3.el6_2.6.x86_64
18/24
  Installing :
php-snmp-5.3.3-3.el6_2.6.x86_64
19/24

PostgreSQL an APACHE runs normal and PHP does not recognize
php_pgsql/pdo_pgsql.

How i fix this mess?

Thanks.

--------------------------------------
Rudinei Dias


More information about the CentOS mailing list