[CentOS] mismatch in openssh latest rpm available at centos

Brian Mathis brian.mathis+centos at betteradmin.com
Wed Mar 28 21:22:12 EDT 2012


On Wed, Mar 28, 2012 at 9:05 PM, Vinay Nagrik <vnagrik at gmail.com> wrote:
> Hello Group,
>
> The latest rpm in openssh is 5.8, however, the corresponding latest rpm
> available in centos 5.7  is only
>     openssh-4.3p2-72.el5_6.3.x86_64.rpm
> and in 6.0 centos is
>    openssh-5.3p1-20.el6.x86_64.rpm
>
> I have following questions.
> 1. I want to start from src.rpm and where can I get the src.rpm for
> openssh-5.3p1-20.el6.x86_64.rpm.
> 2. Can I install openssh-5.3p1-20.el6.x86_64.rpm SAFELY with 5.7 centos
> without causing any problems.
> 3. Which of these two rpms will be most compatible with latest openssh rpm
> version 5.8.
>
> Please let me know.  It is important for my work.
>
> Any help will be greatly appreciated.
> Nagrik


You may want to read about how Redhat and thus CentOS handles package
versions with regard to security patches, etc...  There is information
here:
    https://access.redhat.com/security/updates/backporting/

As for obtaining the most recent version of openssh for other reasons
(such as features), it is strongly recommended against compiling your
own, and instead installing the package from another publicly accepted
repository, such as EPEL or RepoForge.  Any packages on there have
already been compiled and tested to work with your version of CentOS.
I would avoid installing the C6 version of openssh on C5, and instead
make sure to get the proper package meant for C5.


❧ Brian Mathis


More information about the CentOS mailing list