[CentOS] SSHMenu (Gnome Applet) for CentOS 6

Nikolaos Milas nmilas at noa.gr
Fri Nov 2 16:45:16 UTC 2012


On 2/11/2012 9:35 πμ, Nikolaos Milas wrote:

> Can someone advise on how to find/create an el6 RPM for
> gnome-applet-sshmenu?

I've finally managed to create a working RPM. I'll post details and a 
src.rpm when I can - it will take some time to make it clean enough for 
publication.

For those who are interested in using SSHMenu in Gnome 2 / Centos 6, 
here is the quick and dirty way (the following are for an x86_64 system, 
but it should be very similar for i386):

Install:
     ruby
     ruby-libs
from base repo.

Then:

ruby-gconf2-0.19.3-3.el6.opsec.x86_64
ruby-cairo-1.4.1-2.el6.opsec.x86_64
ruby-atk-0.19.3-3.el6.opsec.x86_64
ruby-gnome2-0.19.3-3.el6.opsec.x86_64
ruby-pango-0.19.3-3.el6.opsec.x86_64
ruby-gtk2-0.19.3-3.el6.opsec.x86_64
ruby-panelapplet2-0.19.3-3.el6.opsec.x86_64
ruby-gdkpixbuf2-0.19.3-3.el6.opsec.x86_64
ruby-libart2-0.19.3-3.el6.opsec.x86_64
ruby-glib2-0.19.3-3.el6.opsec.x86_64
ruby-gnomecanvas2-0.19.3-3.el6.opsec.x86_64

from: http://rpm.centoshelp.org/el6/

Then, install:
     sshmenu-3.18-7.el6.noarch
from:
     http://dl.marmotte.net/rpms/redhat/el6/x86_64/

and, finally my RPM, which you can find here:

http://www.eurobjects.com/files/gnome-applet-sshmenu-3.18-7.el6.noarch.rpm

Enjoy!

Nick



More information about the CentOS mailing list