[CentOS] PHP version dilemma

Luigi Rosa lists at luigirosa.com
Fri Oct 5 14:00:20 EDT 2012


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Todd Cary said the following on 05/10/12 19:45:

> However, I am not sure what you mean by
> 
> and then install the php53 packages you previously had

if the output of rpm -q --all | grep php is  (for instance)

php
php-cli
php-gd
php-mysql

you should yum install this packages:

php53
php53-cli
php53-gd
php53-mysql

> Another question has to do with the GD library.  How can I tell if it is
> installed *or* is it automatically part of php35?

I can answer your question: it is not included in php53 package; you have to
install php53-gd

> Oh yes...if there is a problem with php35, are there any problems in
> reinstalling php 5.1?

If everithing fails, just remove the php53 packages, yum install the php
packages you removed and restore /etc/php.ini



Ciao,
luigi

- -- 
/
+--[Luigi Rosa]--
\

Statistics are used as a drunken man uses lamp posts: For support rather than
illumination.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iEYEARECAAYFAlBvIDQACgkQ3kWu7Tfl6ZSNYwCdETGMMzCM5GJ5iSqeJJ3stDbM
YMAAoK8TWfuM1IFtOb5KCRSXExzXg9+6
=lB+C
-----END PGP SIGNATURE-----


More information about the CentOS mailing list