[CentOS] PHP version dilemma

Todd Cary todd at aristesoftware.com
Fri Oct 5 15:04:54 EDT 2012


What is the best way around this problem:

Resolving Dependencies
--> Running transaction check
---> Package php53.i386 0:5.3.3-13.el5_8 set to be updated
--> Processing Dependency: php53-common = 5.3.3-13.el5_8 for package:
php53
--> Processing Dependency: php53-cli = 5.3.3-13.el5_8 for package: php53
--> Running transaction check
---> Package php53-cli.i386 0:5.3.3-13.el5_8 set to be updated
---> Package php53-common.i386 0:5.3.3-13.el5_8 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-13.el5_8.i386 from updates has depsolving problems
   --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
  You could try using --skip-broken to work around the problem
  You could try running: package-cleanup --problems
                         package-cleanup --dupes
                         rpm -Va --nofiles --nodigest


I ran yum remove php.  Should I have done more?

Todd





More information about the CentOS mailing list