[CentOS] centos 5 and php53

m.roth at 5-cent.us m.roth at 5-cent.us
Wed Oct 17 13:54:06 EDT 2012


John R Pierce wrote:
> On 10/14/12 10:18 PM, John R Pierce wrote:
>> I have a long running webserver, runs a bunch of mostly php+postgresql
>> stuff, mostly hobby sites (clubs and local scout troops and such).   has
>> latest updates to php 5.2.10-xx  but I want to install something thats
>> insisting on php53.   If I try and yum install php53, it says it
>> conflicts with php-5.2.10 ...
>
> so, upon more digging, I figured out this php-5.2.10 had come from
> c5-testing or somethign, and was no longer there.  I hooked up to IUS
> and installed their php52 as it turns out other stuff I'm running claims
> not to work with 5.3 without me oding a whole bunch of major
> upgrading/reimlementing of webpiles...    so IUS set me up with 5.2.17
> and I'm happy.  The thing I was installing wanted at least 5.2.11

You really want to talk to the folks whose website(s) it/they are, and
point out to them that php 5.2 is obsolete, and full of bugs and security
holes, and sooner or later *all* maintenance will go away, and they will
be SOL, and they need to be thinking about porting it to 5.3 soon, as in
starting last month.

       mark



More information about the CentOS mailing list