[CentOS] rpmlib(PayloadIsLzma

Leonard den Ottolander leonard at den.ottolander.nl
Wed Sep 5 06:50:07 EDT 2012


Hello Michel,

On Tue, 2012-09-04 at 21:47 -0400, Michel Donais wrote:
>  Hylafax-Server 6.0.5-1rhel5.i386.rpm
>  Hylafax-Client-6.0.5-1rhel5.i386.rpm
>  
>         rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by yajhfc-0.5.2-1.noarch
> 
>  On my system
>  rpm is at level 4.4.2.3-28.el5_8

This rpm is not suitable for use on CentOS-5, despite the version string
suggesting it to be. The compression algorithm it uses is not available
in the version of rpm used on C5. It is used in rpm on C6 and recent
versions of Fedora. (Although SUSE initiated the move to lzma this got
integrated into rpm and is not exclusive to their distros, see
https://bugzilla.redhat.com/show_bug.cgi?id=441110 .) You could unpack
the rpm on either of the aforementioned systems or get yourself a
tarball instead. Perhaps you could notify the packager and inform him of
his mistake.

Regards,
Leonard.

-- 
mount -t life -o ro /dev/dna /genetic/research




More information about the CentOS mailing list