[Arm-dev] Unable to get X working on respberry pi centOs

Johnny Hughes johnny at centos.org
Tue Apr 12 14:41:13 UTC 2016

On 04/10/2016 11:43 AM, Sam Bruner wrote:
> Ok.  I did more digging in hopes of trying to fix this issue with manually compiling something and then trying yum again.
> What is strange is normally this error appears to be related to opengtk-X11 not jtk 
> I guess I can wait until the desktop or gnome groups get updated but I would like to attempt a fix to move past not having a gui.
> Can anyone shed light on this
> Sent from my iPad
>> On Apr 3, 2016, at 7:46 PM, Sam Bruner <sabruner3 at juno.com> wrote:
>> I downloaded the raspberry pi 2 centOs image.  It was supposed to support X.  The minimal image did not contain X or a desktop.  I tried to install X and was not successful.  I then tried to install gnome desktop from the available yum groups.
>> I got the error 
>> Java-1.7.0-openjdk-headless- (updates)
>> Requires libations-headless-X11-2.0.so.0
>> I searched all available packages for this file and did not find one with the sources configured in the base image for yum libraries.
>> How can I get X and a web browser run on the centOs respberry pi 2.
>> I really would like gnome or kde.

Gnome SHOULD work from the devel repos .. it will not work from the
released repos.

But, the GNOME is dead slow on the RPI 2.  In conjunction with the
community, we need some accelerated drivers, etc. to make xorg perform
better on the RPI2 or RPI3 .. we have yet to give that much focus.

Look Here (base distro os builds):

And here (updates):

for things that are not in the released tree.  We have closure on the
released tree and not all packages for now.

Johnny Hughes

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/arm-dev/attachments/20160412/69cb0c3d/attachment.sig>

More information about the Arm-dev mailing list