[Arm-dev] Gigabyte MP30-AR0

LOIC DEVULDER loic.devulder at mpsa.com
Thu Apr 14 08:53:30 UTC 2016


No I haven't tried to add a GPU. My motherboard is in a R120-P30 server which I will use as a test web server and/or virtualization server, and I haven't a GPU card at my disposal. Sorry.


De : Ronald Maas [ronaldjmaas at gmail.com]
Envoyé : jeudi 14 avril 2016 05:37
Cc : Conversations around CentOS on ARM hardware (arm-dev at centos.org)
Objet : Re: Re: [Arm-dev] Gigabyte MP30-AR0

Hi Loic,

I asked a question to someone working for Applied Micro, and he
confirmed it was a known issue and that they are working on it. He
also advised to compile xgene_enet as built-in driver instead of using
it as a module.

Other question. Did you have any luck installing a PCIe video card and
starting either Gnome or KDE desktop? So far I tried nVidia 7800 GT
(from Apple G5) and Radeon 290X. Although both are recognized by
lspci, X fails to start. Also dmesg shows some ugly crashes.

Kind regards,

On Tue, Apr 12, 2016 at 5:48 AM, LOIC DEVULDER <loic.devulder at mpsa.com> wrote:
> Hi Ronald,
> openSUSE installs without problem but as you already know the network is not working due to the fact that the xgene_enet is compiled as a module...
> I'm compiling an openSUSE kernel with this module statically linked and I will see whats happen next.
> But it's strange to see that the module is not working (lsmod shows 0 for the 'used' column, strange...).
> Regards,
> Loic
> -----Message d'origine-----
> De : Ronald Maas [mailto:ronaldjmaas at gmail.com]
> Envoyé : samedi 9 avril 2016 07:17
> À : LOIC DEVULDER - U329683
> Objet : Fwd: Re: [Arm-dev] Gigabyte MP30-AR0
> ---------- Forwarded message ----------
> From: Ronald Maas <ronaldjmaas at gmail.com>
> Date: Fri, Apr 8, 2016 at 7:02 PM
> Subject: Re: Re: [Arm-dev] Gigabyte MP30-AR0
> To: arm-dev at centos.org
> Hi Loic,
> Centos 7.2 is actually the easiest distribution to install as the
> xgene_enet driver is build in the kernel instead of compiled as a
> module. Only thing needed was setting the MAC0 / MAC1 variables in
> UEFI shell. And then after the Centos installer started, open a Linux
> shell and run
> dhclient eth0
> A lot of good information about MP30-AR0 can be found at
> https://rwmj.wordpress.com/
> Debian and OpenSuse could be installed using the full DVD installation
> image, but then you either need to recompile the kernel or use an
> alternative PCIe ethernet adapter (haven't tried that). For details
> how to change .config and recompile the kernel for Debian Testing see
> https://lists.debian.org/debian-efi/2016/03/msg00020.html
> Something similar should work for OpenSuse
> Kind regards,
> Ronald Maas

More information about the Arm-dev mailing list