[Arm-dev] Gigabyte MP30-AR0

Phong Vo pvo at apm.com
Wed Feb 24 01:24:23 UTC 2016

Thanks, Mike.

I never used the graphical installer before, but adding ip=dhcp to the
grub command line does the trick then.


-----Original Message-----
From: arm-dev-bounces at centos.org [mailto:arm-dev-bounces at centos.org] On
Behalf Of Michael Howard
Sent: Tuesday, February 23, 2016 7:15 PM
To: arm-dev at centos.org
Subject: Re: [Arm-dev] Gigabyte MP30-AR0

On 23/02/2016 11:58, Phong Vo wrote:
> I see that CentOS installer somehow does not detect network, so it gives
> text-based installation.
> However, once installation is finished, check your
> /etc/sysconfig/network-scripts/ifcfg-eth0
> (or something similar).
> Make sure
> Change ONBOOT to y and reboot should get network working.

Yes, I did that but it was still no go. The problem with the installed
system was that I hadn't set the hardware address in UEFI (set MAC0
xx:xx:xx:xx:xx:xx), after that networking worked.

The installer still didn't detect a connection on any of the nics,
though I could assign an ip manually at the shell. Editing grub command
line before running the installer cured that issue.


Mike Howard

Arm-dev mailing list
Arm-dev at centos.org

More information about the Arm-dev mailing list