[Arm-dev] Attempt to install Xfce by hand

Robert Moskowitz rgm at htt-consult.com
Fri Oct 12 13:20:30 UTC 2018


I have reached a point where having an Xfce desktop would be REALLY 
valuable for supporting my servers by VNCing into the DE.

So is there any possible progress on fixing errors in epel1?  Also 
adding the XFCE missing group that mainline Centos7 has?

thanks

On 8/7/18 10:16 AM, Robert Moskowitz wrote:
> You may have seen my posts around on my challenges to build a couple 
> groups to do a group install.  That got me to realize, that I probably 
> know which rpms to install and I could 'do it by hand' for now.  So 
> first step was:
>
> yum install glx-utils initial-setup-gui mesa-dri-drivers 
> plymouth-system-theme spice-vdagent xorg-x11-drivers 
> xorg-x11-server-Xorg xorg-x11-utils xorg-x11-xauth xorg-x11-xinit 
> xvattr tigervnc-server wayland-protocols-devel xorg-x11-drv-keyboard 
> xorg-x11-drv-libinput xorg-x11-drv-mouse xorg-x11-drv-openchrome
>
> Where xorg-x11-drv-openchrome was not available, but is flagged 
> optional in the group.  This installed 16 packages and 263 dependents.
>
> Next the actual Xfce:
>
> yum install Thunar xfce-utils xfce4-panel xfce4-session xfce4-settings 
> xfconf xfdesktop xfwm4 gdm leafpad openssh-askpass orage polkit-gnome 
> thunar-archive-plugin thunar-volman tumbler xfce4-appfinder 
> xfce4-icon-theme xfce4-power-manager xfce4-session-engines 
> xfce4-terminal xfwm4-theme-nodoka xfwm4-themes pinentry
>
> First this showed:
>
> No package xfce-utils available.
> No package leafpad available.
> No package thunar-archive-plugin available.
> No package xfce4-icon-theme available.
> No package xfwm4-theme-nodoka available.
>
> No leafpad is OK, as a check shows that mousepad is available and this 
> is what is in Fedora28.  No xfce-utils is not good.  It got worst with 
> critical missing dependencies that need to be fixed before I could get 
> this to work:
>
> Error: Package: xfce4-power-manager-1.4.1-4.el7.armv7hl (epel)
>            Requires: libxfce4util.so.6
>            Available: libxfce4util-4.10.1-2.el7.armv7hl (epel)
>                libxfce4util.so.6
>            Installing: libxfce4util-4.12.1-2.el7.armv7hl (epel)
>               ~libxfce4util.so.7
> Error: Package: xfdesktop-4.10.3-1.el7.armv7hl (epel)
>            Requires: libxfce4util.so.6
>            Available: libxfce4util-4.10.1-2.el7.armv7hl (epel)
>                libxfce4util.so.6
>            Installing: libxfce4util-4.12.1-2.el7.armv7hl (epel)
>               ~libxfce4util.so.7
> Error: Package: xfce4-session-4.10.1-8.el7.armv7hl (epel)
>            Requires: libxfce4util.so.6
>            Available: libxfce4util-4.10.1-2.el7.armv7hl (epel)
>                libxfce4util.so.6
>            Installing: libxfce4util-4.12.1-2.el7.armv7hl (epel)
>               ~libxfce4util.so.7
> Error: Package: orage-4.10.0-5.el7.armv7hl (epel)
>            Requires: libxfce4util.so.6
>            Available: libxfce4util-4.10.1-2.el7.armv7hl (epel)
>                libxfce4util.so.6
>            Installing: libxfce4util-4.12.1-2.el7.armv7hl (epel)
>               ~libxfce4util.so.7
> Error: Package: Thunar-1.6.3-2.el7.armv7hl (epel)
>            Requires: libxfce4util.so.6
>            Available: libxfce4util-4.10.1-2.el7.armv7hl (epel)
>                libxfce4util.so.6
>            Installing: libxfce4util-4.12.1-2.el7.armv7hl (epel)
>               ~libxfce4util.so.7
> Error: Package: xfce4-appfinder-4.10.1-2.el7.armv7hl (epel)
>            Requires: libxfce4util.so.6
>            Available: libxfce4util-4.10.1-2.el7.armv7hl (epel)
>                libxfce4util.so.6
>            Installing: libxfce4util-4.12.1-2.el7.armv7hl (epel)
>               ~libxfce4util.so.7
> Error: Package: xfce4-session-engines-4.10.1-8.el7.armv7hl (epel)
>            Requires: libxfce4util.so.6
>            Available: libxfce4util-4.10.1-2.el7.armv7hl (epel)
>                libxfce4util.so.6
>            Installing: libxfce4util-4.12.1-2.el7.armv7hl (epel)
>               ~libxfce4util.so.7
> Error: Package: thunar-volman-0.8.0-6.el7.armv7hl (epel)
>            Requires: libxfce4util.so.6
>            Available: libxfce4util-4.10.1-2.el7.armv7hl (epel)
>                libxfce4util.so.6
>            Installing: libxfce4util-4.12.1-2.el7.armv7hl (epel)
>               ~libxfce4util.so.7
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
>
> I am going to have to put this on the back burner until someone can 
> fix these.  I do not have the skill sets to do it.
>
> But having Xcfe would be great for an armv7 SOC over Gnome!
>
>
> _______________________________________________
> Arm-dev mailing list
> Arm-dev at centos.org
> https://lists.centos.org/mailman/listinfo/arm-dev



More information about the Arm-dev mailing list