[Arm-dev] Attempt to install Xfce by hand

Johnny Hughes johnny at centos.org
Thu Oct 18 21:04:18 UTC 2018

On 10/18/2018 03:07 PM, Robert Moskowitz wrote:
> On 10/18/18 3:55 PM, Johnny Hughes wrote:
>> On 10/18/2018 02:43 PM, Robert Moskowitz wrote:
>>> On 10/18/18 3:32 PM, Johnny Hughes wrote:
>>>> On 10/18/2018 12:36 PM, Robert Moskowitz wrote:
>>>>> Some progress
>>>>> On 10/17/18 8:30 PM, Robert Moskowitz wrote:
>>>>>> Johnny,
>>>>>> I have this new keyboard with a poorly positioned Del key, and I
>>>>>> deleted your message in such a way that it seems to be gone.  So I
>>>>>> went to the archive and pulled it up there.
>>>>>> yum group install Xfce "X Window System"
>>>>>> Helped.  It added 6 packages plus 21 dependencies:
>>>>>> Installing for group install "X Window System":
>>>>>>    plymouth-system-theme    armv7hl 0.8.9-0.31.20140113.el7.centos
>>>>>> base     31 k
>>>>>>    spice-vdagent            armv7hl 0.14.0-15.el7 base     66 k
>>>>>>    xorg-x11-drivers         armv7hl 7.7-6.el7 base    8.3 k
>>>>>>    xorg-x11-server-Xorg     armv7hl 1.19.5-5.el7 base    1.2 M
>>>>>>    xorg-x11-utils           armv7hl 7.5-22.el7 base    107 k
>>>>>>    xvattr                   armv7hl 1.3-27.el7 base     22 k
>>>>>> But I am now at the situation where the login fails and I end up
>>>>>> right
>>>>>> back at the login page.  I looked at the message log and see the
>>>>>> following:
>>>>> .....
>>>>> I have had some help in private exchanges and have done the following:
>>>>> yum install avahi gnome-backgrounds
>>>>> systemctl enable avahi-daemon
>>>>> systemctl start avahi-daemon
>>>>> this took care of a number of errors, but why gnome-backgrounds for
>>>>> Xfce
>>>>> to deal with the message:
>>>>> Oct 17 20:17:39 ct-c7 journal: Failed to load background
>>>>> 'file:///usr/share/backgrounds/gnome/adwaita-lock.jpg': Error opening
>>>>> file /usr/share/backgrounds/gnome/adwaita-lock.jpg: No such file or
>>>>> directory
>>>>> But still a couple of unresolved errors that are stopping the login:
>>>>> =============private exchange=====================
>>>>>> Oct 18 10:45:34 ct-c7 journal: Some code accessed the property
>>>>>> 'AuthList' on
>>>>>> the module 'authList'. That property was defined with 'let' or
>>>>>> 'const' inside
>>>>>> the module. This was previously supported, but is not correct
>>>>>> according to the
>>>>>> ES6 standard. Any symbols to be exported from a module must be
>>>>>> defined with
>>>>>> 'var'. The property access will work as previously for the time
>>>>>> being, but
>>>>>> please fix your code anyway.
>>>>> gnome-shell --- a nasty piece of work, and one the Gnome Mafia
>>>>> want to cram down our throats
>>>>> Fedora next ship was blocked by this for a while ....
>>>>> definitely file a bug and carp publicly
>>>>> =============end private exchange=====================
>>>>> So to publicly carp...
>>>>> I even tried installing gnome-shell:
>>>>> # yum install gnome-shell
>>>>> Loaded plugins: fastestmirror
>>>>> Loading mirror speeds from cached hostfile
>>>>>    * base: mirror.siena.edu
>>>>>    * centos-kernel: mirror.siena.edu
>>>>>    * extras: mirror.siena.edu
>>>>>    * updates: mirror.siena.edu
>>>>> Package gnome-shell-3.26.2-5.el7.armv7hl already installed and latest
>>>>> version
>>>>> Nothing to do
>>>>> So what does it want?  This is a bug...
>>>>>    And along with the above message is:
>>>>> Oct 18 10:45:36 ct-c7 org.gnome.Shell.desktop: Window manager
>>>>> warning: "XF86RFKill" is not a valid accelerator
>>>>> This is also a bug to file with a need for that the accelerator not
>>>>> be called when the modules is absent, as on arm?
>>>>> So I think I am getting closer to running Xfce, but stumbling along
>>>>> the way.
>>>>> All help on the above greatly appreciated.
>>>> The good (and bad :D) news is .. I have tried to install xfce on my
>>>> cubbietruck plus .. and I have hit the same issue.
>>>> I am going to try to get it working now.
>>>> If I get it working, I'll post the solution.
>>> thanks for digging into this.  I was looking for a x86 box to do a
>>> 'standard' minimal install and then install Xfce and see what was being
>>> dropped on the box.  Thing is, where do I have an x86 box here other
>>> than my notebook?
>> I am quite sure the issue is some pieces GNOME need to be installed to
>> make everything work.
>> I am going to try 2 things:
>> 1) a gnome desktop install .. but afterwards only use xfce
> I can confirm that this works.  It is how I got my first working Xfce,
> see my post back on 10-14 9:34am EDT.

This does work .. so we really just need to figure out the minimum
number of packages to make this work.

BTW . firefox is absolutely not usable with a 2GB cubietruck_plus in xfce.

If someone wanted to seriously use this setup, it would not be on this

>> 2) try with mate and lightdm and not gdm for the main screen .. then use
>> xfce or mate
> It would be nice to use lightdm rather than gdm on arm.  Fedora is, but
> then I found some bugs on lightdm that have since been fixed (otherwise
> F29 would not be in beta, as it was a blocker or something like that).
> I looked at mate, but had already adjusted to xfce thanks to it
> appearing in the first Fedora-arm images.

I'll see if I can figure out what is missing to make xfce  work with a
minimal install.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/arm-dev/attachments/20181018/8a592597/attachment.sig>

More information about the Arm-dev mailing list