[Arm-dev] Problems installing yum-utils on one system

Robert Moskowitz rgm at htt-consult.com
Wed Jan 9 15:30:59 UTC 2019


I have yum-utils on two systems, but for some reason, it has dependency 
issues on another.

[root at onlo rgm]# yum install yum-utils
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package yum-utils.noarch 0:1.1.31-50.el7 will be installed
--> Processing Dependency: python-kitchen for package: 
yum-utils-1.1.31-50.el7.noarch
--> Processing Dependency: libxml2-python for package: 
yum-utils-1.1.31-50.el7.noarch
--> Running transaction check
---> Package libxml2-python.armv7hl 0:2.9.1-6.el7_2.3 will be installed
--> Processing Dependency: libxml2 = 2.9.1-6.el7_2.3 for package: 
libxml2-python-2.9.1-6.el7_2.3.armv7hl
---> Package python-kitchen.noarch 0:1.1.1-5.el7 will be installed
--> Processing Dependency: python-chardet for package: 
python-kitchen-1.1.1-5.el7.noarch
--> Running transaction check
---> Package libxml2-python.armv7hl 0:2.9.1-6.el7_2.3 will be installed
--> Processing Dependency: libxml2 = 2.9.1-6.el7_2.3 for package: 
libxml2-python-2.9.1-6.el7_2.3.armv7hl
---> Package python-chardet.noarch 0:2.2.1-1.el7_1 will be installed
--> Finished Dependency Resolution
Error: Package: libxml2-python-2.9.1-6.el7_2.3.armv7hl (base)
            Requires: libxml2 = 2.9.1-6.el7_2.3
            Installed: libxml2-2.9.1-6.el7.3.armv7hl (@centos-base_rbf)
                libxml2 = 2.9.1-6.el7.3
            Available: libxml2-2.9.1-6.el7_2.3.armv7hl (base)
                libxml2 = 2.9.1-6.el7_2.3
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest

What do I need to do to get it installed?

thanks



More information about the Arm-dev mailing list