[CentOS-devel] OpenLDAP in c4-testing

Matt Hyclak hyclak at math.ohiou.edu
Tue Aug 29 11:49:50 UTC 2006

On Tue, Aug 29, 2006 at 10:47:45AM +0200, Ralph Angenendt enlightened us:
> Matt Hyclak wrote:
> > Has anyone tried to get the OpenLDAP in c4-testing to do authentication? I
> > keep getting this in my logs:
> > 
> > Aug 28 14:44:58 finite sshd: PAM [dlerror: /usr/lib64/libldap-2.2.so.7:
> > undefined symbol: SSL_CTX_set_tmp_rsa_callback]
> Still on 4.3:
> [angenenr at shutdown lib]$rpm -qf libldap.a
> openldap-devel-2.2.13-4
> [angenenr at shutdown lib]$nm libldap.a | grep rsa_callback
> nm: kbind.o: no symbols
> nm:          U SSL_CTX_set_tmp_rsa_callback
> version.o: no symbols
> [angenenr at shutdown lib]$
> You might want to look if "your" libldap.a still has that symbol in it
> ...

[root at finite ~]# nm /usr/lib64/libldap.a | grep rsa_callback
nm: kbind.o: no symbols
                 U SSL_CTX_set_tmp_rsa_callback

I've also tried updating the FC Devel to 2.3.27 (per the suggestion of the RH
OpenLDAP maintainer) with the same results. I'm going to try rebuilding
directly on the server to make sure it's not something stupid on the build


Matt Hyclak
Department of Mathematics 
Department of Social Work
Ohio University
(740) 593-1263

More information about the CentOS-devel mailing list