[CentOS-devel] Re: kernel in testing

Fri Dec 22 09:00:40 UTC 2006
Kay Diederichs <kay.diederichs at uni-konstanz.de>

Karanbir Singh wrote:
> hi Kay,
> Kay Diederichs wrote:
>>> Ditto, except I would like to flag the following error that came up at
>>> installation:
>>> Running Transaction
>>>   Installing: kernel                       #########################
>>> [1/1]
>>> /lib/modules/2.6.9-42.28.EL.c4test/kernel/arch/i386/kernel/cpu/cpufreq/powernow-k8.ko 
>>> needs unknown symbol cpu_online_map
>> I get the same message during installation. But this kernel solves 
>> problems with our new hardware (Fujitsu-Siemens Amilo notebook with 
>> SATA ICH7 Intel Dualcore), that with the 2.6.9.-42.0.3 kernel requires 
>> "acpi=off irqpoll" (and is still unstable with these options).
> errr.. dont use it on a production machine, it might be a long time 
> before it shows up in the released tree...

The 2.6.9-42.28.EL.c4test kernel is the only way to use Centos 4.4 on 
this hardware. SuSe 10.x with x > 0 also appears to work.

> Also, you got an Athlon powernow-k8 message on the CoreDuo laptop ?? Can 
> you please provide the output from /proc/cpuinfo and dmesg please ( 
> attach it at a bug report at http://bugs.centos.org/ and let us know the 
> bug no please )
> - KB


the powernow-k8 module is irrelevant for this hardware (Genuine Intel(R) 
CPU  T2400  @ 1.83GHz) .

However, I now tried the 2.6.9-42.28.EL.c4test kernel on a Mac Pro 
(which works very well with 2.6.18, except for a non-functional optical 
drive). It hangs during booting  at "Probing PCI bus", after identifying 
the CPUs; with or without acpi=off. Of course the 2.6.9-42.0.3 also does 
not work with this hardware, but I was encouraged by the success with 
the notebook.

I also tried on a Dell Precision 670. Here the kernel hangs after
"Uncompressing Linux" before starting "Redhat nash". This is unexpected 
because all CentOS kernels so far worked on this hardware.

On the latter two platforms I get during installation
Failed to mmap 

Failed to mmap ./drivers/net/wireless/ipw2100/Makefile

Failed to mmap 

Failed to mmap ./drivers/net/wireless/ipw2200/Makefile

Failed to mmap 

Will file a bug as you suggested.