[CentOS-devel] Building a custom 2.6.9 kernel

Fri Feb 3 20:34:06 UTC 2006
Matt Hyclak <hyclak at math.ohiou.edu>

On Fri, Feb 03, 2006 at 03:22:19PM -0500, William L. Thomson Jr. enlightened us:
> > These are only the kernel headers. They won't help you.
> You keep saying that, but they do contain a full source. I made a kernel
> with this one kernel-devel-2.6.9-22.EL.i686.rpm. As offered on IRC, I
> can do each command again, and pastebin the output.

No, they really don't. I just listed the files in a kernel-devel rpm and the
only .c files are in the scripts directory. It's pretty hard to compile the
kernel without any source.

> I also provided links to the kernel I built using it, and the config?
> So FACT is it's much more than headers, and does contain a complete
> source, at least for i686.

Try again.

> > I really doubt this. The devel packages aren't all the source. It's
> > just what you need to build against the kernel, not to build a new
> > kernel.
> Stop doubting, look for yourself, or attempt for yourself. rpm install
> the package. Then move the sources to /usr/src. Copy my config into that
> dir, and build a kernel. Just like I did.

The rpm installs to /usr/src/kernels/$VERSION

I suggest you browse that directory again and note the lack of .c files.

> I am not a troll, and had legitimate questions, one can choose to answer
> or ignore. Never got an answer of it someone had successfully compiled a
> x86_64 kernel using CentOS sources.

What do you think people run?

> >  You're not paying anything for the distribution,
> > and you're not RUNNING the distribution, you're building its kernel
> > outside of its environment. I fail to see a driving need for us to
> > offer help for that.
> Neither am I paying on the gentoo side. I have asked way more CentOS/RH
> specific questions in the Gentoo forum, and get no flack. They are not
> claiming to be an enterprise community distro. Like CentOS, so there
> should be a higher tolerance on CentOS. Seems there is not on the
> channel and allot of bias attitudes.
> Instead of focusing on actually help. Which one does not have to, the
> moderators could have just ignored. Not like I was interrupting other
> conversations, being rude, or using foul language.
> Guess the irc channel is a dictatorship, with little room for freedom of
> speech and choice.

No, you were asking off-topic questions. Just because you were bastardizing
source code from CentOS doesn't mean we need to support it. Why don't you go
ask in #redhat and see how it goes over. Better yet, open a bugzilla entry. 

> For the last time. I did. If you keep insisting it's impossible I will
> gladly reproduce steps, and provide bash_history. Or do it yourself and
> see. I am not lying or making this up. No point in that?

See above. Do an rpm -qpl kernel-devel-foo.rpm. Look for .c files. 

> > These are two seperate kernel versions. You can't expect to mix and
> > match between the two. has been updated for security
> > reasons. Running it means you'll be running a kernel with
> > vulnerabilities.
> Um, I am suing a 2.6.9-22 kernel just renaming it to 2.6.9-11 so the
> binary driver will not bitch on modprobe or insmod. Look at the config
> file and you will see I tag on the local revision.
> However I have mentioned the security reasons to Adaptec, who only
> offers binaries ATM for 2.6.9-11.EL
> > Are you using the same build environment the kernel is expecting? Have
> > you applied all the patches. Are you using actual kernel source
> > instead of the -devel packages?
> Tried the actual sources had patching problems. The kernel-devel package
> was properly patched, and worked perfectly in x86 i686. Just not x86_64.
> > Have you applied the patches. It's possible that the patches create
> > the additional files you need. or that somewhere through this
> > nightmare of a build process something failed silently or was
> > excluded.
> Actually I had the exact problem I am having by a particular patch.
> Because I ran into it before when applying patches to the src rpm kernel
> sources. I have considered using the src.rpm to reverse that patch out
> of the x86_64 kernel-devel rpm. So I am leaning more to a patch causing
> the problem than not. I find it hard to believe a vanilla 2.6.9 kernel
> source would not compile a x86_64 kernel
> > You should really be seeking help from within the gentoo community
> > rather than trying to piece two drastically different distros
> > together. This will only end badly for you. If it's running on another
> > distro, why again should we assist your efforts?
> I have, and they are doing their best to help. FYI, allot of the missing
> stuff is there in the Gentoo kernel sources, and current vanilla ones.
> So the problem is most deff CentOS/RH specific. So they can't help, thus
> me starting by asking if anyone has build a custom x86_64 kernel on
> centos.

CentOS merely takes what RH gives us. If you are so convinced the problem
lies there, take it up with them.

Matt Hyclak
Department of Mathematics 
Department of Social Work
Ohio University
(740) 593-1263