[CentOS-devel] php-pear from dev.centos.org repo

Jim Perrin jperrin at gmail.com
Fri Nov 10 19:43:33 UTC 2006

> Has anyone else seen this?  What am I doing wrong?

Yes, and nothing. It's something I screwed up in the packaging with
the requires checking, and hits a limitation in yum. It's not a yum
bug, just an interesting handling method when dealing with epoch.
Basically when we roll out the new version (should be soon) instead of
requiring php-pear, the new php rpms will be modified to require
php-pear >= 1:1.4.9, which will force it to use the newer php-pear in

This is a prime example of why things go into dev before hitting
centosplus or other repos, and why feedback is good. Thank you for
bringing this up and discussing it. To everyone else reading along...

During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell

More information about the CentOS-devel mailing list