[CentOS-devel] building centos livecd [was [Fwd: Re: [CentOS] unionfs and centos 4.4]

Fri Nov 10 03:00:54 UTC 2006
beast <beast at ldap.or.id>

Sorry for cross posting, but this might the appropriate list.


-------- Original Message --------
Subject: 	Re: [CentOS] unionfs and centos 4.4
Date: 	Thu, 09 Nov 2006 17:28:59 +0700
From: 	beast <beast at ldap.or.id>
To: 	CentOS mailing list <centos at centos.org>
References: 	<45505F60.2010109 at ldap.or.id> 
<1162902346.5010.81.camel at myth.home.local>

Johnny Hughes wrote:
> On Tue, 2006-11-07 at 17:26 +0700, beast wrote:
>> I have tried to create a livecd from Centos 4.4, it require to compile 
>> unionfs as a module.
>> I'm using Centos kernel source kernel-2.6.9-42.EL.src.rpm and unionfs 
>> v1.1.5 but its giving error while compiling. 
>> <http://mirror.linux.duke.edu/pub/centos/4.4/os/SRPMS/kernel-2.6.9-42.EL.src.rpm>
>> Is anyone having success story building centos livecd from scratch?
>> --beast
> There is a unionfs module that you can use already on the liveCD ...
> just copy it into place in the new kernel directory and do:
> depmod -a
> The version used on the liveCD is also in the tar file here:
> http://mirror.centos.org/centos/4/build/livecd/
I have tried to build using livecd-0.9.1.tgz, but it gives the error 
while booting the CD:

starting unionfs support
insmod: cannot insert module '/tmp/unionfs.ko': invalid module format: 
(-1): Exec format error
error inserting module unionfs (1)

I have followed README instructions, including compile unionfs againts 
current kernel (kernel-2.6.9-42.livecd.c4) and able to modprobe unionfs 

The instructions seems different from the original linux-live script README:
1. it compile squashfs int kernel, while LL-script expect to find 
squashfs.ko (however from the boot msg, it seems able to load squashfs, 
no error)
2. it ask for different kernel version (ie `uname -r`_i686)
3. modify the existing linux isntallation (or do i ned to chroot before 
running build-livecd.sh -sl ?)

Many thanks.