[CentOS-devel] CentOS-4.4 yumconf

John Summerfield debian at herakles.homelinux.org
Thu Sep 7 14:35:06 UTC 2006

Matt Hyclak wrote:
> On Thu, Sep 07, 2006 at 10:09:08PM +0800, John Summerfield enlightened us:
>>Matt Hyclak wrote:
>>>>>Won't this also cause problems when upgrading to the next release?
>>>>Of course it will. :-(
>>>Not with proper exclude= lines in your configuration it won't. After all,
>>>since you made the centos-release package yourself, you can control what
>>>goes in that file, so an exclude line should be trivial.
>>Doesn't Anaconda look at the release file to see what it's supposed to 
>>upgrade _from_? If it doesn't recognise it, how will it know how to upgrade?
> Have we moved away from yum into respun CDs?

No, I was thinking of the upgrade many folk will want to do to CentOS 5.

If folk are creating alternative release packages I wonder whether they 
will create problems for themselves at that time.

While Anaconda has an argument to force it to upgrade, and it would 
almost certainly work upgrading CentOS4 (or even WBEL) to CentOS5, it's 
not the sort of thing people should use in the ordinary course of events.



-- spambait
1aaaaaaa at coco.merseine.nu  Z1aaaaaaa at coco.merseine.nu
Tourist pics http://portgeographe.environmentaldisasters.cds.merseine.nu/

Please do not reply off-list

More information about the CentOS-devel mailing list