[CentOS-devel] evil centosplus dependency circle

Jim Perrin jperrin at gmail.com
Tue Feb 27 23:53:43 UTC 2007

On 2/27/07, Michael Gabriel <irzyxel at gmail.com> wrote:
> trying a yum update on mysql, postgres or php forces the others to install.
> is that really wanted ??

This is yum's behavior, because you have these packages installed on
your system.  Try it with an --exclude mysq*,postgres*  and it'll work
just fine. You can get around this by using an includepkg or exclude
statement in the repository config file as documented in the wiki
entry centosplus http://wiki.centos.org/Repositories/CentOSPlus

During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell

More information about the CentOS-devel mailing list