[CentOS-devel] Migrating from RH9 Legacy to CentOS 3

Sun Jan 7 19:25:00 UTC 2007
R P Herrold <herrold at owlriver.com>

On Fri, 5 Jan 2007, David Eisner wrote:

> R P Herrold wrote:
>> On Tue, 24 Oct 2006, David Eisner wrote:
>>> With the end of Legacy support for RH9, I'd like to migrate my Fedora
>>> Legacified RH9 box to Centos 3.

>>>  http://www.owlriver.com/tips/centos-31-ex-rhl-9/

>>> Any thoughts on whether this should also work with the .legacy packages?

>> As author of the migration instructions in question, let me give an
>> unqualified "Yes, probably" ....  ;)

> 1. The Centos-3.8 isos for CD 1 and 3 both had a 
> comps-3.8centos.0-0.20060803.i386.rpm package, which were 
> not identical. I used the CD 3 version.

noted, wearing my 'CentOS' hat - thanks for the report -- U9 
whould be along in reasonably soon which will get a respin, 
but we'll look for that in the CentOS build process

>        "yum -y -t -c /etc/yum-upgrade.conf upgrade rpm kernel",

>           [Segmentation fault happened here]

hmmm --- wish I had more information here -- probably the 
instructions need to be updated to suggest removing all 
but the kernel in use; a pre-conversion 'yum -y clean all' 
would probably be prophylactic as well.

> To solve this, I first tried upgrading python from python-2.2.2-26 to
> python-2.2.3-26, using an RPM downloaded from www.python.org.  This

ouch -- python version dependent matters are _so_ integral to 
a Red Hat derived system, that I consider that pretty 'daring'

> 3. Step 8. has one run the same two commands twice.  The 
> second time I ran "rpm -vv --rebuilddb", it was not happy:

> I rebooted, and then the rebuilddb worked.  The second "yum 
> -y -t -c /etc/yum-upgrade.conf upgrade rpm kernel" ran and, 
> not surprisingly, told me there were no upgrades available.

We are in terra incognita here with the python version 
possibly in play; I think my instructions whould suggest the 
reboot before the first and second rebuilddb's again, not for 
a known issue, but to make sure we are under the new kernel

> 4. Step 9. worked fine, it just took awhile.  However, a few 
> .legacy packages remained:

> $ rpm -qa |grep legacy
> sendmail-cf-8.12.11-4.24.1.legacy
> fetchmail-6.2.0-3.4.legacy
> libpng10-1.0.15-0.9.1.legacy
> gettext-0.11.4-7.2.legacy
> kernel-2.4.20-46.9.legacy
> tcpdump-3.7.2-7.9.4.legacy
> libpcap-0.7.2-7.9.4.legacy
> kernel-2.4.20-43.9.legacy
> zip-2.3-
> sendmail-8.12.11-4.24.1.legacy

I had not considered this later versioned material (when the 
outline was written, it was in the future, and unknowable as 
to how this would play out), as the path I outlined from RHL 9 
would not encounter it;  I will approach other members of the 
CentOS team in the topic of how we are to offer a path to 
'care' for the people orphaned by the EOL of FL.

btw, Kudos to Jesse and the folks who kept FL running for the 
two years or so it ran -- I know how difficult starting and 
running a distribution is, and a great effort and success were 
the result.

> I removed the legacy kernel packages, and "upgraded" the 
> rest manually with rpm -Uvh --force.  That seems to have 
> worked.  Then I rebooted.

I will consider adding a section about 'housekeeping' to 
identify and get back onto the CentOS main line path for the 
FL transitioners.  seems like a good idea.  Thanks for noting 

> Finally I replaced /etc/yum.conf with the sample given in 
> the Owl River instructions, and it appears to be working 
> (there were two packages available for updating (GConf and 
> oaf) which I was able to do with no problems).

Great -- Thank You, David.

-- Russ Herrold