[CentOS-devel] yum 2.4.3 updates for CentOS 3 and 4 in the testing repo

Michael Paesold mpaesold at gmx.at
Mon Jun 18 10:58:05 UTC 2007

Daniel de Kok wrote:
> Hmmm, did it happen to install python2.3 as a dependency? This package
> has a provides for python-optik, "blocking" the python-optik package
> from CentOS base being installed.
> I just filed a bug for this:
> http://bugs.centos.org/view.php?id=2152

Not related to this issue, but I have found a server where the new yum 
does not update default kernels correctly ("Could not determine the 
default kernel!). The only thing I see that could cause this, is that 
the server does not have a boot partition, so this is grub.conf (after 
manually updating default to 0):

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have no /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/hda2
#          initrd /boot/initrd-version.img
title CentOS (2.4.21-50.EL)
         root (hd0,0)
         kernel /boot/vmlinuz-2.4.21-50.EL ro root=LABEL=/
         initrd /boot/initrd-2.4.21-50.EL.img
title CentOS (2.4.21-47.EL)
         root (hd0,0)
         kernel /boot/vmlinuz-2.4.21-47.EL ro root=LABEL=/
         initrd /boot/initrd-2.4.21-47.EL.img

Is it possible that not having a boot partition is the reason for this 
failure? Otherwise I could try to look more closely.

Best Regards
Michael Paesold

More information about the CentOS-devel mailing list