[CentOS-devel] Trying to recompile the openldap overlay smbk5pwd with the -DDO_KRB5 option

Scott Grizzard scott at scottgrizzard.com
Mon Apr 14 16:52:15 UTC 2008

I have heimdal and openldap installed on a server.  I used the openldap 
binaries from the testing branch, and I installed heimdal from source 
with the --with-openldap option.  When I try to use the smbk5pwd module 
to sync heimdal and ldap passwords, I receive the following error:

Checking configuration files for slapd:  /etc/openldap/slapd.conf: line 
167: smbk5pwd: <smbk5pwd-enable> module "smbk5pwd-enable" only allowed 
when compiled with -DDO_KRB5.

I downloaded and installed the src.rpm from testing, but I don't know 
how to recompile the overlays rpm with that option.  Can someone tell me 
how to do this?

- Scott

More information about the CentOS-devel mailing list