[CentOS-devel] Too many kernels?

Axel Thimm Axel.Thimm at ATrpms.net
Thu Jul 3 14:32:28 UTC 2008


currently ATrpms builds kmdls for the following RHEL5/CentOS5 kernels
(actually for CentOS it also builds plus for plus kernels, but let's
keep the discussion simple):

    el5/2.6.18-92.1.6.el5 \
    el5/2.6.18-92.1.1.el5 \
    el5/2.6.18-92.el5 \
    el5/2.6.18-53.1.21.el5 \
    el5/2.6.18-53.1.19.el5 \
    el5/2.6.18-53.1.14.el5 \
    el5/2.6.18-53.1.13.el5 \
    el5/2.6.18-53.1.6.el5 \
    el5/2.6.18-53.1.4.el5 \
    el5/2.6.18-53.el5 \
    el5/2.6.18-8.1.15.el5 \
    el5/2.6.18-8.1.14.el5 \
    el5/2.6.18-8.1.10.el5 \
    el5/2.6.18-8.1.8.el5 \
    el5/2.6.18-8.1.6.el5 \
    el5/2.6.18-8.1.4.el5 \
    el5/2.6.18-8.1.3.el5 \
    el5/2.6.18-8.1.1.el5 \
    el5/2.6.18-8.el5 \

Similar for RHEL4/3. This slows down kmdl updates as say for a new
nvidia driver one need to build kmdls for all these kernels in all
flavours/archs etc.

I start to think whether these kernels are indeed being all used to
the extend of justifying full kmdl support. Maybe it would make sense
to keep the full last series (2.6.18-92* above) and the highest one
from the series before (2.6.18-53.1.21.el5 and 2.6.18-8.1.15.el5).

Or is there any other idea? What are Red Hat's, CentOS' policies wrt
support of kernels? ATrpms should probably just copy that policy and
drop kernel support once the respective upstream support drops it.
Axel.Thimm at ATrpms.net

More information about the CentOS-devel mailing list