[CentOS-devel] perl-devel package

Manuel Wolfshant wolfy at nobugconsulting.ro
Wed Jul 30 21:29:06 UTC 2008

On 07/31/2008 12:02 AM, Charlie Brady wrote:
> On Wed, 30 Jul 2008, Kenneth Porter wrote:
>> I wanted to install the latest Subversion, version 1.5.1, on CentOS 5.
> ...
>> This is mostly a heads-up to others that might run into this, but I'm 
>> wondering what the best way to deal with it is. Should I comment out 
>> the BuildReq, or create a virtual package that provides perl-devel 
>> and depends on the existing perl package?
> I would just rpmbuild with --nodeps.
Wrong approach. Apply Johnny's advice. Or be polite and modify the spec 
to distinguish between building on fedora >=7  or on Centos (RHEL).
Something along the following line should do:

%if 0%{?fedora} > 6
  BuildRequires perl-devel
  BuildRequires perl

More information about the CentOS-devel mailing list