[CentOS-devel] apr-devel and httpd-devel packaging problem

James Antill james at fedoraproject.com
Mon Jun 30 12:41:35 UTC 2008

On Sun, 2008-06-29 at 23:57 +0200, Ralph Angenendt wrote:
> Morning,
> we seem to have a packaging problem with httpd-devel.x86_64 and
> apr-devel.x86_64.
> If you install httpd-devel on an x86_64 machine, apr-devel is required
> by this package.
> It then goes on to install apr-devel - but the i386 version.

 This is an ongoing problem in yum/rpm/Fedora/etc. where packages want
arch deps. but rpm does not yet offer them (very new rpm fills in
%{_isa} to solve this problem).
 Atm. it's not really a packaging problem or a yum problem, although you
can work around it by using a file dep. in the package ... or by doing
excludes in yum (or telling yum to install apr-devel.x86_64 by hand).

James Antill <james at fedoraproject.com>

More information about the CentOS-devel mailing list