[CentOS-devel] Centos 5.3 dependency check?

Hugo van der Kooij hvdkooij at vanderkooij.org
Sun Apr 5 15:12:24 UTC 2009

Hash: SHA1

Markus Falb wrote:
> Hugo van der Kooij wrote:
>> It seems that a package is now added to perl in Centos 5.3 that was not
>> there before.
>> So a dependency on perl-MIME-Base64 will fail because that package now
>> seems to colide with perl itself. (SIGHHHH)
>> How can I change my spec file to list the requirement only for
>> Centos/RHEL 5.x where x < 3?
> hmm. strange enough:
> # cat /etc/redhat-release 
> CentOS release 5.2 (Final)
> # rpm -q --whatprovides 'perl(MIME::Base64)'
> perl-5.8.8-15.el5_2.1
> maybe the conditional requirement is not necessary. try a:
> Require: perl(MIME::Base64)

That is not valid.

error: line 30: Unknown tag: Require: perl(MIME::Base64)

Because RH makes a habit of including new packages into perl itself and
using relative old ones there is a definite need to build a package with
 an up-to-date version of this.


- --
hvdkooij at vanderkooij.org               http://hugo.vanderkooij.org/
PGP/GPG? Use: http://hugo.vanderkooij.org/0x58F19981.asc

	A: Yes.
	>Q: Are you sure?
	>>A: Because it reverses the logical flow of conversation.
	>>>Q: Why is top posting frowned upon?

Bored? Click on http://spamornot.org/ and rate those images.
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the CentOS-devel mailing list