[CentOS-devel] there's something happened between kernel 2.6.28-128.1.1 and 2.6.18-128.1.6 compilation

Farkas Levente lfarkas at lfarkas.org
Sun Apr 19 15:30:17 UTC 2009

it seems there should happened something with centos build system
between kernel 2.6.28-128.1.1 and 2.6.18-128.1.6 compilation. because
although the two spec files only differs with a few dozen of patches the
resulted src.rpm are different ie:
# rpm -qp --requires kernel-2.6.18-128.1.1.el5.src.rpm | grep unifdef
# rpm -qp --requires kernel-2.6.18-128.1.6.el5.src.rpm | grep unifdef
and this small differences means the latest kernel can't be compiled in
what's more the same is not true for rhel's kernel ie. in case of rhel's
2.6.18-128.1.6 it gives unifdef. so it's a centos bug and with this bug
centos don't follow upstream behavior.
just my 2c.

  Levente                               "Si vis pacem para bellum!"

More information about the CentOS-devel mailing list