[CentOS-devel] How to handle kABI when patching kernel

Giovanni Tirloni gtirloni at sysdroid.com
Wed Apr 18 10:43:38 UTC 2012

On Wed, Apr 18, 2012 at 3:44 AM, Mike Schmidt <mike.schmidt at intello.com>wrote:

> Hi,
> I've generated (via rpmbuild) a patched version of the latest CentoS 6.2
> kernel (2.6.32-220.7.1)  with the imq patchset (
> http://www.linuximq.net/patches.html), but this causes the kABI to break.
> What can orshould I do about this, if anything?
> What kinds of changes cause the kABI to break? Would it be reasonable to
> think I might be able to fix the patch to be kABI compliant?
> Is the kABI for CentOS the same as the one for the upstream RHEL version?
> Should I try to patch the kABI (as Oracle does in their unbreakable linux
> kernel)? What would be the procedure foir this?

Yes, it's the same as the upstream's. You can either fix the code or
disable the checks at your own risk.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos-devel/attachments/20120418/86b4fe5e/attachment.html>

More information about the CentOS-devel mailing list