[CentOS-devel] snd_hda_intel module tweaking

Tue Apr 22 12:43:01 UTC 2014
Alan Bartlett <ajb at elrepo.org>

On 22 April 2014 01:37, Chris Pemberton <cjpembo at gmail.com> wrote:
> On 4/21/2014 6:38 PM, Chris Pemberton wrote:
>> On 04/21/2014 05:37 PM, Chris Pemberton wrote:
>>> Long story short... I'm recompiling the snd_hda_intel module to
>>> enable CONFIG_SND_HDA_RECONFIG.  This will allow me to reset the pins
>>> on the card to get my sound working.  (This option is already set in
>>> arch and ubuntu - where I can reprogram my pins and get sound working).
>>> I followed the 2 CentOS wikis pertaining to getting the full kernel
>>> sources and compiling a module... all seemed to go perfect.
>>> Unfortunately, when I try to load the new snd_hda_intel.ko module, I
>>> get the following:
>>> FATAL: Error inserting snd_hda_intel
>>> (/lib/modules/2.6.32-431.11.2.el6.x86_64/extra/snd-hda-intel.ko):
>>> Invalid module format
>>> A little googling suggested I run 'file' on the two modules and here
>>> is the output:
>>> /lib/modules/2.6.32-431.11.2.el6.x86_64/extra/snd-hda-intel.ko: ELF
>>> 64-bit LSB relocatable, x86-64, version 1 (SYSV), not stripped
>>> /lib/modules/2.6.32-431.11.2.el6.x86_64/kernel/sound/pci/hda/snd-hda-intel.ko:
>>> ELF 64-bit LSB relocatable, x86-64, version 1 (SYSV), not stripped
>>> They seem identical?  Any suggestions where I could go from here? I'm
>>> currently recompiling the entire kernel and will just copy over the
>>> new modules and see if something better happens.
>>> Thanks,
>>> Chris
>> UPDATE:  I compiled the entire kernel and then just copied over the
>> needed snd modules into /lib/modules/.../extra
>> Now I get this when I try to load the module:
>> Module signed with unknown public key
>> ksign: module signed with unknown public key
>> - signature keyid: 3000b37e8a34083d ver=4
>> Google suggests the following; neither worked:
>> objcopy -R .note.module_sig snd-hda-intel.ko
>>     or
>> objcopy -R .module_sig snd-hda-intel.ko
>> Any hints?
>> Chris
> 2nd UPDATE:
> Finally just installed the entire newly-compiled kernel, (reminded me of
> my old days with gentoo) with the only change being snd_hda_intel's
> CONFIG_SND_HDA_RECONFIG set.  Audio works great (Beats Audio).  Really
> wish I knew more about module signing so I could use the "stock" kernel".
> I guess I'll probe further sometime with KMOD module compiling to see if
> it will somehow solve the signing issue.
> Chris
> _______________________________________________
> CentOS-devel mailing list
> CentOS-devel at centos.org
> http://lists.centos.org/mailman/listinfo/centos-devel


This m/l, CentOS-devel, is for discussions relating to the
_development_ of the CentOS Project. You really should use the CentOS
(users') m/l for your general query.

That said, please examine the output produced by executing modinfo on
each of your modules.