[CentOS-devel] Upgrade tool patching and debugging.

Wed Jul 9 21:25:55 UTC 2014
Laurent Rineau <laurent.rineau__fedora at normalesup.org>

Le mercredi 02 juillet 2014 20:07:46 Jim Perrin a écrit :
> Now that we've got c7 mostly finalized we're starting to look at the
> upgrade tool. There are several moving pieces for the upgrade tool that
> will need some patching to work properly.
> For anyone who's interesting in taking a dive into the code and helping
> out, we have some first-run binaries located at
> http://dev.centos.org/centos/6/upg/  with the source living on
> git.centos.org
> These binaries will most likely not work, but they should provide a
> decent starting point for testing and debugging.

I have tried to upgrade an installation of CentOS 6.5 to 7.0, using:

  sudo redhat-upgrade-tool --force --iso=/home/lrineau/CentOS-7.0-1406-x86_64-Everything/CentOS-7.0-1406-x86_64-Everything.iso

I have to use --force, because I did run preupg just before, but redhat-upgrade-tool tells me I did not.

My / and /boot and on sort RAID1 partitions (with mdadm). After reboot on the upgrade image, dracut says:

[  189.272697] localhost dracut-initqueue[476]: Warning: Could not boot.
[  189.333232] localhost dracut-initqueue[476]: Warning: /dev/disk/by-uuid/7605c90b-ab65-4165-94d2-94b91d23a5d8 does not exist

The corresponding disk is the / on RAID1.

I have tried to add "rd.md=1" as option on the kernel line, in grub, but during the boot to the upgrade image, the log says:

[    3.272702] localhost dracut-pre-trigger[369]: rd.md=0: removing MD RAID activation

and indeed my RAID partitions are not detected. In the dracut emergency shell, mdadm is able to assemble my RAID with: `mdadm --assemble --scan`, but I do not know how to work around that issue.

Laurent Rineau