[CentOS-devel] Upgrade tool patching and debugging.

Wed Jul 16 01:50:30 UTC 2014
Johnny Hughes <johnny at centos.org>

On 07/15/2014 04:01 PM, gaurav chaturvedi wrote:
> Hello,
>   I did a minimal install in Virtualbox for Centos 6 and tried to
> upgrade using the upgrade tools, from centos's repo[1]. But this tends
> to fail[2].
> preupg --list comes up blank.
>   After this I directly proceeded to use redhat-upgrade-tool, as it
> turns out I need to use --force since preupg failed.
> The exact commend used is "redhat-upgrade-tool --force --network 7.0
> --instrepo http://mirror.centos.org/centos-7/7/os/x86_64/"
> This works, I encountered errors like[3], but after installing the
> CentOS 7 keys manually everything worked out.
> In the end I had a bootable and upgraded CentOS 7 box.
> Cheers,
>   Gaurav
> [1] http://dev.centos.org/centos/6/upg/x86_64/Packages/
> [2] http://i.imgur.com/zd1HOKV.png
> [3] http://i.imgur.com/7bU1nU7.png

Thanks for the feedback .. now lets see if we can get some smart people
to help us fix the pre-update tool :)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/centos-devel/attachments/20140715/2f6efacc/attachment-0007.sig>